Finn.Rad – Når vi vil kombinere informasjon fra flere ark

with Ingen kommentarer
Hyggelig om du deler:
Share on Facebook
Facebook
Tweet about this on Twitter
Twitter
Share on LinkedIn
Linkedin

english-versionFinn.Rad er en av funksjonene jeg bruker oftest i Excel. Hvis du har forskjellig informasjon på faner som du vil knytte sammen, er den helt knall.

(Artikkelen fortsetter under videoruten. Excelboken som benyttes i videoen kan du laste ned i bunnen av artikkelen)

 

Tabellene som knyttes sammen i dette eksemplet:

Fanen Navn

Ansattnummer, Navn (Årslønn og Bosted skal hentes fra de andre fanene)

Årslønn og bostedskommune skal hentes fra de neste fanene:

Fanen Årslønn

Ansattnummer, Årslønn

 

Fanen Kommune

Ansattnummer og bostedskommune

 

Det som forteller hvilke rader i fanene som som hører sammen, er Ansattnummeret i første kolonne på hver fane.

Nummer 1 Ola, har årslønnen som har nummeret 1 på fanen som heter Årslønn, og bor i kommunen som har nummeret 1 på fanen Kommune.

Linjenummeret som ansattnummeret står i spiller ingen rolle (Dette skulle vært tydeligere i videoen!)

 

Formelen i celle C2 er:

=FINN.RAD(A2;Årslønn!A:B;2;USANN)

Forklaring til formelen

=FINN.RAD(A2;Årslønn!A:B;2;USANN)

«A2» forteller at vi leter etter nummeret 1.

=FINN.RAD(A2;Årslønn!A:B;2;USANN)

«Årslønn!A:B» forteller at Excel skal lete i kolonnene A til B i fanen Årslønn. Verdien vi leter etter må ligge i A-kolonnen, altså den første i utvalget.

Hadde utvalget vårt vært Årslønn!B:C og vi ville ha informasjonen fra kolonnen C, ville dette parameteret fortsatt vært 2, siden C er den andre kolonnen i utvalget.

=FINN.RAD(A2;Årslønn!A:B;2;USANN)

2 sier at den skal hente verdien i kolonne nummer to av de kolonnene vi har valgt (A:B).

=FINN.RAD(A2;Årslønn!A:B;2;USANN)

USANN sier at vi kun godtar en eksakt treff, mens SANN ville ha returnert den verdien som ligner mest.

 

Det er viktig å merke seg at verdien vi søker etter alltid må være den første i utvalget.

Bruker vi Årslønn!A:B som her, vil funksjonen søke etter en lik verdi i kolonne A

Bruker vi Årslønn!B:Z, vil funksjonen søke etter en lik verdi i kolonne B

Kolonnene vi vil hente frem, må derfor alltid ligge til høyre for kolonnen vi leter etter. Hvis det ikke er tilfelle, kan oppgaven løses med Indeks og Sammenligne.

 

Se også: Avansert bruk av finn.rad

Se også: FinnDelRad – når ikke Finn.Rad kan benyttes

Se også: Når Finn.Rad ikke virker

Last ned Excelarket her: FinnRad.xlsm (3705 downloads)