Sammenligne to kolonner

with Ingen kommentarer

Sammenligne to kolonner i Excel.

Dette behovet dukker opp ganske ofte. Enten jeg holder på med regnskap, fakturering eller kundeoppfølging, får jeg behov for å sjekke eksisterende tall, kundenummer etc mot nye.

Tre måter å gjøre det på

I dette eksemplet ser vi på hvordan vi kan sammenligne to kolonner i Excel på tre forskjellige måter:

  1. Benytte funksjonen Finn.Rad
  2. Benytte funksjonen Sammenligne
  3. Benytte betinget formatering for å fremheve verdiene vi har fra før.

(Artikkelen fortsetter under videoruten)

Benytte funksjonen Finn.Rad

sammenligne to kolonner

Formelen vi ender opp med i celle  B2, er

=HVISFEIL(FINN.RAD(A2;'Ark2'!A:A;1;USANN);"-")

 

Vi starter med en litt enklere variant:

=FINN.RAD(A2;'Ark2'!A:A;1;USANN)

A2 er verdien vi skal lete etter i Ark2

‘Ark2’!A:A er kolonnen i Ark2 vi skal lete i

1 forteller at Finn.Rad skal returnere verdien i første kolonne, som jo er A

USANN betyr at vi krever at finn.rad skal finne en verdi som er eksakt lik den vi søker etter, ikke bare tilnærmet lik.

Tall – eller feil…

sammenligne to kolonner

Da har vi kommet så langt at Finn.Rad returnerer tallet hvis det finnes i Ark2, men hvis den ikke finner tallet, returneres #I/T som ikke er særlig fint å vise til sjefen.

Da pakker vi formelen inn i HVISFEIL, som gjør at vi kan bestemme hvilken verdi som skal settes inn hvis funksjonen feiler.

=HVISFEIL(FINN.RAD(A2;'Ark2'!A:A;1;USANN);"-")

Nå vises enten den tilsvarende verdien i kolonne B, eventuelt en minus «-«, som er verdien vi ber HVISFEIL sette inn hvis finn.rad feiler.

Greit nok. Men hvis vi skal jobbe videre med tallene, kan det være greit at det vises en fast verdi, f.eks «*» der tallet finnes i stedet for tallet selv. Da kan vi hive på en HVIS og skrive formelen slik

=HVISFEIL(HVIS(FINN.RAD(A2;'Ark2'!A:A;1;USANN);"*");"-")

 

Sammenligne to kolonner – med Sammenligne

sammenligne to kolonner
fig.2

Nå skal vi gjøre samme øvelsen med Sammenligne. Sammenligne returnerer nummeret på raden som er lik den vi søker etter, mens Finn.Rad returnerer celleverdien på raden. Med Finn.Rad kan vi også velge å returnere verdien fra en kolonne til høyre for kolonnen vi har funnet verdien i. Begge funksjoner kan benyttes til denne oppgaven.

Formelen vi ender opp med her i C2 er

=HVISFEIL(HVIS(SAMMENLIGNE(A2;'Ark2'!A:A;0);"*";"");"-")

 

Vi deler den opp litt

=SAMMENLIGNE(A2;'Ark2'!A:A;0)

 

A2 er verdien vi leter etter

‘Ark2’!A:A er området vi vil lete i

0 betyr at vi skal ha en eksakt lik verdi, ikke bare tilnærmet

Slik formelen er her, ender vi opp med enten et linjenummer fra kolonne A i Ark2, eller verdien #I/T.

Så legger vi på en HVIS:

=HVIS(SAMMENLIGNE(A2;'Ark2'!A:A;0);"*";"")

 

Det vi oppnår nå, er at hvis sammenligne returnerer et tall, returnerer HVIS «*», en stjerne. Det andre parametret er tomt, «», og vil aldri bli benyttet, siden sammenligne enten returnerer en verdi – eller feiler med #I/T.

For å få formelen til å returnere «-«, en bindestrek hvis tallet ikke finnes, er å bestemme hva som skal returneres hvis formelen feiler. Vi pakker formelen inn i HVISFEIL:

=HVISFEIL(HVIS(SAMMENLIGNE(A2;'Ark2'!A:A;0);"*";"");"-")

 

Nå vises en «*» hvis sammenligne finner en lik verdi, eller en «-» hvis den ikke finner noe og feiler.

Sammenligne to kolonner med Betinget formatering

sammenligne to kolonner
fig.3

 

I dette eksemplet legger vi på en grønn bakgrunnsfarge hvis tallet finnes i Ark2. Denne løsningen er egnet hvis vi bare vil vise hvilke tall vi har fra tidligere. Hvis du skal behandle radene som er like, ville jeg valgt en av de andre metodene.

sammenligne to kolonner
fig.4

Jeg markerer A-kolonnen og velger Betinget formatering, og at jeg vil bruke en formel til å bestemme hvilke celles som skal formateres.

Siden jeg har valgt hele kolonnen, skriver jeg at jeg vil sammenligne A1 med kolonnen i Ark2. Du kan gjøre øvelsen selv og se hva som skjer hvis du setter inn A2 i stedet 🙂

Som du ser av formelen, trenger vi ikke noe HVISFEIL for å bestemme hva som skal skje hvis formelen feiler. Betingelsen er enten sann eller usann.

Last ned regnearket her:  Sammenligne-To-Kolonner.xlsx (208 downloads)