Finn.Rad virker ikke og alt er bare dr#I/T

with Ingen kommentarer

Finn.Rad virker ikke!

(Joooda – den virker alltid)

Erfaringen så langt er at Finn.Rad alltid virker, og at grunnen til at formelen ikke fungerer er at vi bare nesten har gjort alt riktig. Når jeg får henvendelser om dette, er de hyppigste problemene:

  • Det søkes etter tekst i en kolonne med tall eller omvendt.
  • Det man søker etter står ikke i første kolonne i søkeområdet – det må det alltid gjøre.
Abonner på ExcelGurus Youtube-kanal
(Artikkelen fortsetter under videoruten. Excelboken som benyttes i videoen kan du laste ned i bunnen av artikkelen)

 

Slik løser du problemet hvis du søker etter tall i en tekstkolonne eller omvendt

1. Sjekk at du ikke har satt på justering på kolonnen du slår opp mot. 

Finn.Rad virker ikke

Endre justering av kolonnen løser IKKE problemet – det endrer kun hvordan kolonnen vises.

 

2. Hvis tallene er venstrejustert i kolonnen, oppfatter Excel verdiene som tekst

Dette oppstår oftest ved import av data hvor det er en miks av tall og tekst i kolonnen.

 

3. Hvis tallene er høyrejustert, oppfatter Excel verdiene som tall

 

 

4. Hvis formelen din returnerer en feil, kan det hende at du søker etter tall i en kolonne som Excel oppfatter som tekst. Da blir resultatet slik:

finn.rad virker ikke

Formelen i E2 er i dette tilfellet

=FINN.RAD(D2;A1:B5;2;USANN)

Siden D2 er et tall, og Excel oppfatter verdiene i A-kolonnen som tekst, returnerer formelen #I/T – ikke tilgjengelig.

5. For å få Excel til å finne verdien, må vi søke med en tekst i A-kolonnen, og konverterer derfor D2 fra tall til tekst ved hjelp av Tekst-funksjonen:

=FINN.RAD(TEKST(D2;"##");A1:B5;2;USANN)

finn.rad virker ikke

 

Nå søker funksjonen finn.rad etter en tekst i en kolonne med tekst, vipps – så fungerer formelen 🙂

 

Ta en kikk på videoen – der viser jeg hvordan du kan søke deg frem til de aller vanligste kildene til feil når du bruker denne kommandoen. Det kan være vel anvendt tid – jeg bruker Finn.Rad i nesten hvert eneste Excelark jeg lager.

Se også: Hvordan vi kobler informasjon fra forskjellige tabeller

Se også: Avansert bruk av finn.rad

Se også: FinnDelRad – når ikke Finn.Rad kan benyttes

 

Last ned regnearket her:  Finn.Rad_.virkerikkeeeeee.xlsm (454 downloads)