Søke i flere kolonner med FINN.RAD

with Ingen kommentarer

Søke i flere kolonner med FINN.RAD

Når vi søker med Finn.Rad, leter vi etter èn verdi i èn kolonne. Hvordan finner vi frem hvis vi har flere kolonner som skal matche for å hente en verdi? I dette eksemplet benytter vi en hjelpekolonne.

Takk til Martin Bergholtz for innspillet:)

(Artikkelen fortsetter under videoruten)

 

Last ned regnearket her: Oppslagshjelp-Hjelpekolonne-Matriseformel.xlsx (76 downloads)

Oppgaven:

Oppgaven er å fylle inn feltet Beskrivelse i fanen Oversikt (fig.1). Når vi skifter transportmiddel til Buss, skal merknadene for Byen og dette transportmiddelet hentes fra fanen Tabell og dukke opp i Beskrivelse.

Søke i flere kolonner med FINN.RAD
fig.1 – Oversikt

Tabellen vi skal hente verdier fra ser du under (fig.2).

søke i flere kolonner finn.rad
fig.2 – Tabell

Utfordringen

Hvis vi prøver oss med en finn.rad formel for å hente verdier fra Merknadskolonnen oppdager vi kjapt hva som er problemet. I C2 i fanen Oversikt setter vi Formelen

=FINN.RAD($E$2;Tabell!C:D;2;USANN)

Formelen over sier at vi skal lete etter E2 (Buss) i fanen Tabell i kolonne C, og returnere kolonne nummer to av kolonnene C:D, altså kolonne D.

Dollartegnene i $E$2 sørger for at denne referansen ikke endrer seg når vi kopierer formelen nedover.

Når vi drar denne nedover til C6, ser vi (fig.3) at resultatet blir

fig.3 – Oversikt

 

Problemet er at alle formlene finner søkebegrepet «Buss» i celle D2. Det er ingenting som forteller at «Buss» skal være knyttet til f.eks «Bergen». Vi har altså ikke en unik verdi vi kan søke etter i tabellen i fig.2

Lage en unik verdi.

Vi skyter inn en kolonne før A i tabellen, og setter formelen i A2 til

=C2&D2

Resultatet av denne formelen blir OsloBuss, og er unikt for tabellen (fig.4).

Søke i flere kolonner med FINN.RAD
fig.4 – Tabell

Nå endrer vi formelen i oversikten vår til

=FINN.RAD(B2&$E$2;Tabell!A:E;5;USANN)

Formelen sier at vi skal lete etter B2&$E$2 (OsloBuss) i kolonne A i tabellen og returnere den 5. kolonnen i tabellen.

Dollartegnene i $E$2 sørger for at denne referansen ikke endrer seg når vi kopierer formelen nedover.

Når vi drar denne formelen nedover, ser du at Beskrivelsene i C-kolonnen fylles vakkert ut med riktig verdi.

fig.5 – Oversikt

Generelt

Når du skal hente verdier fra tabeller ut fra flere kriterier, kan du sette inn en hjelpekolonne som slår sammen verdiene i kolonnene du søker etter. Du kan slå sammen så mange du vil, f.eks =C2&D2&E2&F2