Sortere en liste ved hjelp av matriseformler

with Ingen kommentarer

ExcelNorgeSortere en liste

Denne gangen viser ExcelNorge steg for steg hvordan vi kan bruke matriseformler for å sortere en liste.

Det er fullt mulig å sortere en liste ved hjelp av valget Data-Sorter i menyen, men endrer du noe, må du sortere manuelt via menyen – og ikke minst huske på å gjøre det. ExcelNorges løsning gjør at listen til enhver tid er sortert.

Formelen han ender opp med, er:

{=INDEKS($A$2:$A$16;SAMMENLIGNE(RADER(F$2:F2);ANTALL.HVIS($A$2:$A$16;”>=”&$A$2:$A$16);0))}

Last ned regnearket og mys på videoen hvis du vil finne ut hva formelen gjør.

Denne sorteringen har en begrensning – den håndterer ikke at det er like navn i listen.

Jeg fryder meg over ExcelNorge sine eksempler. ExcelNorge bruker en helt annen tilnærming enn meg for å løse oppgavene, og det spraker frydefullt mellom øra når jeg ser eksemplene.

Last ned regnearket her: ET-0006.xlsx (152 downloads)