Når HVIS() ikke strekker til

with 1 kommentar

Er det vanskelig å få det til med HVIS(), skal du sannsynligvis ikke bruke HVIS().

Last gjerne ned regnearket før du leser videre: HVIS-og-alternativene-til-HVIS.xlsx (433 downloads)

HVIS()

HVIS du synes formlene blir for komplekse med HVIS(), kan du ofte ha større nytte av f.eks FINN.RAD(). En HVIS-formel som skal finne månedens navn ut fra nummeret, kan se slik ut:

(Eksemplene forutsetter at det står et tall mellom 1 og 12 i celle A2)

=HVIS(A2=1;»Januar»;HVIS(A2=2;»Februar»;HVIS(A2=3;»Mars»;HVIS(A2=4;»April»;HVIS(A2=5;»Mai»;HVIS(A2=6;»Juni»;HVIS(A2=7;»Juli»;HVIS(A2=8;»August»;HVIS(A2=9;»September»;HVIS(A2=10;»Oktober»;HVIS(A2=11;»November»;HVIS(A2=12;»Desember»;»»))))))))))))

Eksempler på HVIS()

FINN.RAD()

Det fungerer fint i eksemplet over, og så går det an å bruke FINN.RAD(), og da kan formelen bli adskillig kortere. I dette tilfellet har vi en liste i kolonne G og H med månedsnummer og navn som formelen slå opp i

=FINN.RAD(A2;G:H;2;USANN) 

Eksempler på FINN.RAD()

INDEKS() og SAMMENLIGNE()

Du kan også bruke kombinasjonen INDEKS() og SAMMENLIGNE(). Her slår vi også opp i tabellen i kolonne G og H. Fordelen fremfor FINN.RAD() er at rekkefølgen på innholdet i kolonnene G og H ikke spiller noen rolle.

Eksempler på INDEKS() og SAMMENLIGNE()

I dette spesifikke tilfellet kan vi også bruke funksjonen TEKST()

=TEKST(«01.» & A2 & «.2014″;»mmmm»)

Eksempler på TEKST()

 

One Response

  1. HVIS | Excel Guru
    |

    […] Les også Når HVIS() ikke strekker til […]