Aldri mer FINN.RAD(). Nå er det XOPPSLAG() som gjelder

with Ingen kommentarer

Nå er det XOPPPSLAG() som gjelder.

(Kun tilgjengelig i Office365)

Nå går FINN.RAD() over i historien. Den vil nok leve i mange, mange år, men XOPPSLAG() (eng XLOOKUP) erstatter FINN.RAD().

XOPPSLAG

Så hva er så lurt med XOPPSLAG, da?

Eksempelformel:

=XOPPSLAG(A2;Årslønn!B:B;Årslønn!A:A;”Finnes ikke”)

1) Du kan bestemme verdien som skal returneres hvis formelen ikke finner søkeverdien din.

Med FINN.RAD må vi pakke inn formelen i HVISFEIL() for å oppnå det samme.
Tilsvarende formel for FINN.RAD ville vært

=HVISFEIL(FINN.RAD(A2;Årslønn!A:B;2;USANN);"Finnes ikke")

XOPPSLAG

Abonner på ExcelGurus Youtube-kanal
(Artikkelen fortsetter under videoruten. Excelboken som benyttes i videoen kan du laste ned i bunnen av artikkelen)

 

Se også hvordan du bruker XOPPSLAG med flere søkekriterier:

 

2) Kolonnen du søker i trenger ikke være først i tabellen (som kreves i FINN.RAD). Du kan søke etter ansattnummer i kolonne B og returnere Årslønnen i kolonne A. 

XOPPSLAG

 

3) Og dette er den råeste forskjellen på FINN.RAD() og XOPPSLAG(). XOPPSLAG() er en matrisefunksjon, og kan returnere flere kolonner.

Eksempelformel:

=XOPPSLAG(A2;Adresse!A:A;Adresse!B:D;”Ikke funnet”)

Denne formelen returnerer kolonnene B til D fra fanen adresse hvis verdien i A2 finnes.
I eksemplet du kan laste ned, vil du se at antall formler vi trenger for å hente adresser til de fire radene reduseres fra 12 til 4.

XOPPSLAG

Hvis du klikker i E- eller F-kolonnen vil du se at formelen er grå. Formelen kan du bare redigere i kolonne D hvor du opprinnelig skrev den inn.

4) Og ikke minst. Det er standard at XOPPSLAG skal returnere verdier ved nøyaktig samsvar, så man kan som hovedregel skippe parameter 5 i formelen. De fleste som har brukt FINN.RAD har ved en eller annen anledning blitt småsprø over en formel ikke har fungert fordi man har glemt å ta med ;USANN til slutt i FINN.RAD-formelen.

XOPPSLAG

 

Les også: XOPPSLAG() med flere søkekriterier – dette er utklassing!

 

Last ned Excelboken her: XOppslag.xlsx (97 downloads)