Om å velge Trøbbel eller Easypeasy når du legger inn data i Excel

with Ingen kommentarer

Trøbbel eller EasyPeasy

Jeg får en del henvendelser om å forenkle mer eller mindre hårreisende formler. I en del av tilfellene  skyldes kompleksiteten at regnearket er bygget opp på en måte som ikke er så heldig.

Artikkelen fortsetter under videoruten

Last ned regnearket her: DataStruktur.xlsx (97 downloads)

Unike kolonneoverskrifter

Når du skal legge inn data i Excel, bør du etterstrebe å ha unike kolonneoverskrifter. Eksempel på dette er:

datastruktur01
fig.1

Her ser du kolonneoverkskriftene på linje 2, Ukedag, Navn, Epler og Bananer. Disse forekommer bare en gang.

Dataene ligger fra linje 3 og nedover. Med en slik struktur er det svært enkelt å summere og presentere dataene.

Summere med unike kolonner (fig.1)

Hvis jeg vil summere antall epler Arne har plukket denne uken, kan jeg bruke formelen

=SUMMERHVIS($B:$B;”Arne”;C:C)

I regnearket står navnet vi vil summere for i celle I3, så formelen blir

=SUMMERHVIS($B:$B;$I3;C:C)

Funksjonen SUMMERHVIS er bygget for å forholde seg til kolonner og rader, og løser dette enkelt.

Dupliserte kolonneoverskrifter

datastruktur02
fig.2

Et eksempel hvor kolonneoverskriftene ikke er unike, ser du her:

Her gjentas Navn, Epler og Bananer for hver tredje kolonne. Dette kompliserer summeringen betydelig.

Summere med dupliserte kolonneoverskrifter(fig.2)

Hvis jeg vil gjøre det samme for oppsettet i fig.2, blir formelen

=SUMMERHVIS($A$4:$A$8;”Arne”;$B$4:$B$8)+SUMMERHVIS($D$4:$D$8;”Arne”;$E$4:$E$8)+SUMMERHVIS($G$4:$G$8;”Arne”;$H$4:$H$8)+SUMMERHVIS($J$4:$J$8;”Arne”;$K$4:$K$8)+SUMMERHVIS($M$4:$M$8;”Arne”;$N$4:$N$8)

I eksempelarket står navnet i celle A13, og da blir formelen

=SUMMERHVIS($A$4:$A$8;$A13;$B$4:$B$8)+SUMMERHVIS($D$4:$D$8;$A13;$E$4:$E$8)+SUMMERHVIS($G$4:$G$8;$A13;$H$4:$H$8)+SUMMERHVIS($J$4:$J$8;$A13;$K$4:$K$8)+SUMMERHVIS($M$4:$M$8;$A13;$N$4:$N$8)

Formelen gjentas like mange ganger som kolonneoverskriftene er gjentatt – en for hver ukedag.

Presentasjon av dataene dine i Pivot.

En annen fordel med å ha unike kolonneoverskrifter, er at du uten videre kan bruke Pivot-tabeller for å presentere dataene dine. (Ta en kikk på videoen for å se hvordan du gjør – det er ikke vanskelig!)

Med et oppsett som i fig.2, er det umiddelbart oversiktlig, men det er unødig vanskelig å behandle dataene.

En Pivottabell med utgangspunkt i fig.1, kan være spesifisert per ukedag og person:

Pivot

eller spesifisert per ukedag:

Pivot

eller for en enkelt person:

Pivot

 

Presentasjon av dataene i Pivot-tabell med utgangspunkt i fig.2

– funker ikke….

Ha en EasyPeasy dag!