Kopiere formler til nytt regneark uten koblinger

with Ingen kommentarer

Kopiere formler

De fleste har vel opplevd å få med seg koblinger til det gamle Excelarket når man skal kopiere formler fra en Excelbok til en annen. Her ser vi på hvordan vi kan fjerne koblingene – og hvordan vi kan unngå at de blir med ved kopiering.

Problemstilling

I det originale Excelboken som heter «KopiereFormler.xlsm», kopierer jeg med meg cella som har en formel som ser slik ut:

=FINN.RAD(A2;Årslønn!A:B;2;USANN)

Når jeg ser på formelen i den nye Excelboken som heter «NyBok.xlsx», ser den plutselig slik ut:

=FINN.RAD(A3;[KopiereFormler.xlsm]Årslønn!A:B;2;USANN)

Hvis Excelboken KopiereFormler ikke er åpnet i Excel, ser formelen slik ut:

=FINN.RAD(A3;’G:\ExcelGuru\[KopiereFormler.xlsm]Årslønn’!A:B;2;USANN)

Formelen inneholder altså  stien til hvor boken er lagret hvis den ikke er åpen i Excel.

(Linjeskiftet i formlene er bare pga plassmangel her. I Excel står den på en linje)

Hvis det jeg vil er at den nye Excelboken NyBok skal slå opp i det gamle regnearket og hente verdien der, er dette utmerket. Men ofte er det ikke det jeg vil. Jeg vil ha samme formel i begge Excelbøkene.

Hvis det er èn formel, er ikke dette noen utfordring, men er det hundrevis eller tusenvis, er det godt å ha et triks i bakhånd.

(Artikkelen fortsetter under videoruten)

Koblinger

Denne delen av formelen er selve koblingen:

‘G:\ExcelGuru\[KopiereFormler.xlsm]Årslønn’

I Excel har du et eget menypunkt for å redigere koblinger, i menyen DATA (fig.1):

Kopiere formler
fig.1

Hvis du klikker på Rediger koblinger, får du opp alle henvisninger til andre Excelbøker (fig.2):

Kopiere formler
fig.2

Nå kan du klikke på Endre Kilde, og bla deg frem til den nye Excelboken, i dette tilfellet «NyBok.xlsx» og klikker åpne. Du forteller altså Excel at den skal bruke en kobling fra NyBok.xlsx til NyBok.xlsx. Excel skjønner tegningen og sletter hele koblingen.

Lagrer du NyBok.xlsx nå, har du en koblingsfri Excelbok.

Du kan laste ned regnearket her hvis du vil teste:
NyBok.xlsx (54 downloads)

Hvordan kopiere uten at koblingene blir opprettet i det hele tatt?

Hvis du kopierer fanene som det refereres til sammen med fanen som inneholder formlene, lager ikke Excel koblinger i selve formlene.

Hold CTRL nede og klikk på fanene du vil kopiere (fig.3)

kopiereformler05
fig.3

Så høyreklikker du og velger Flytt eller Kopier. Huk av for Lag en kopi, velg at du vil kopiere fanene til den nye boken og klikk OK (fig.4)

kopiereformler06
fig.4

Nå kopieres fanene til den nye arbeidsboken, og formlene er uten koblinger.

Det opprettes likevel en kobling mellom Excelbøkene, men denne ene koblingen fjerner du enkelt ved å velge «Bryt kobling» inne på rediger koblinger slik du ser i fig.3

Ha en koblingsfri dag!