Summere fra mange arkfaner

with Ingen kommentarer

Summere fra mange arkfaner

Dette er et spørsmål som dukker opp ganske ofte, og løsningen er herlig enkel. Vi har en haug med arkfaner i regnearket, og ønsker å summere samme celle eller område fra alle fanene – eller noen av fanene.

Hvordan IKKE summere fra mange arkfaner

Hvis vi summerer en og en fane
=SUMMER(Januar!A1;Februar!A1;Mars!A1…)
er det lett å glemme en fane – det blir dessuten mye jobb!

(Artikkelen fortsetter under videoruten. )

Hvordan summere fra mange arkfaner

Summere celleområde

Prinsippet når vi summerer fra flere arkfaner er det samme som når du summerer celler i samme fane. Hvis jeg vil summere cellene A1 til A10, blir formelen

=SUMMER(A1:A10)

Summere «fane-område»

Hvis jeg vil summere celle A1 i fanene Januar til Desember, kan jeg skrive

=SUMMER(Januar:Desember!A1)

Formelen forholder seg til den rekkefølgen fanene vises i:

Summere fra mange faner

At fanene heter Januar og Desember har ingen logisk betydning i denne sammenhengen, så hvis plasseringen av månedene er annerledes, blir resultatet kanskje noe annet enn vi har tenkt:

Summere fra mange faner

Den morsomste måten å gjøre det på

En morsom og sikker løsning er å plassere en tom fane før den første fanen du vil summere og en tom fane etter siste fane du vil summere.

Hvis du f.eks kaller den første tomme fanen for Første og den siste fanen for Siste, kan du summere innholdet i fanene med formelen

=Summer(Første:Siste!A1)

Denne formelen sikrer at du får summert alle faner mellom Første og Siste – uansett hvor mange faner du måtte ha i mellom dem.

Hvis du vil ha summen for første halvår, drar du fanen Siste slik at den står til høyre for fanen Juni, og du vil se at formelen viser summen av A1 for alle fanene som står mellom Første og Siste.

Last ned regnearket her:  SummereFraMangeFaner.xlsx (324 downloads)