Excel hjelp – spørsmal og svar

with Ingen kommentarer

Excel hjelp

Noen av spørsmålene som kommer inn er ikke så omfattende at jeg lager en artikkel. Her samler jeg svar på spørsmål som har kommet inn fra flere. Håper det etter hvert blir nyttig Excel hjelp.


Spørsmål

Jeg får feil på finn.rad formelen min. Den viser bare #REF!. Hva gjør jeg feil?? Formelen er

=FINN.RAD(B5;C1:C10;3;USANN)

Svar

Du gjør ikke mye feil 🙂

Tretallet ditt betyr at du vil ha tak i verdien i den tredje kolonnen i området C1:C10.

Området ditt inneholder bare C-kolonnen, så kolonneverdien må være 1 for at det skal fungere.

Hvis formelen hadde vært

=FINN.RAD(B5;C1:E10;3;USANN)

ville formelen funket, og finn.rad ville returnert verdien i E-kolonnen hvis den fant B5 i C-kolonnen.


Spørsmål

VBA – Visual Basic for applications. Cellereferanser.

Jeg irriterer meg over at jeg må skrive f.eks cells(1,17) når jeg skal referere til celle Q1. Jeg har store regneark med mange kolonner, og sitter og teller meg i hjel!

Svar

Du kan referere til celle Q1 ved å skrive cells(1,»Q»). Lurt?

Det lureste er å lage skrive en funksjon som finner kolonnenummeret for deg. Funksjonen kan søke etter kolonneoverskriften, f.eks «Navn», og returnere nummeret på kolonnen.

Spørsmål

Beregning av gjennomsnitt, men bare med verdier forskjellig fra null

Har to kolonner med tall (A og B). I den tredje kolonnen C skal det lages et gjennomsnitt, enten ved bruk av (A1+B1)/2 eller ved bruk av GJENNOMSNITT. Problemet er at gjennomsnittet bare skal regnes ut når det er tall større enn 0 i begge celler. Hvis f.eks A5 har «2» mens B5 har «0», skal det ikke regnes ut noe i C. Hvordan løser jeg dette?

Svar

Hei på deg! Formelen i C1 kan du skrive

=HVIS(OG(A1;B1);(A1+B1)/2;0)

eller mer forståelig

=HVIS(OG(A1<>0;B1<>0);(A1+B1)/2;0)


Spørsmål

Telle antall celler som starter med et spesielt ord

Jeg ønsker en løsning som teller antall celler i en rad hvor tekstinnholdet starter med et spesielt ord.
I celle C2 skal det telles hvor mange celler i området D2:H2 som starter med ordet «Kake».

Svar

Hei på deg! Formelen blir

=ANTALL.HVIS(D2:H2;»Kake*»)

 

Formelen vil ta med Kakebunn, Kakefyll, Kakehvasomhelst så lenge du har med en * til slutt. Hvis du vil ha med bare hele ord kan du bruke «Kake *» i stedet for «Kake*»


Spørsmål

Finn.Rad returnerer #I/T når den ikke finner noe

Dukket opp et nytt problem for meg. Når Finn.Rad ikke finner verdien jeg søker etter, får jeg opp #I/T.  Er det mulig å få Finn.Rad til å skrive 0 når den ikke finner noe?

 Svar

Hei på deg, og ja, det er mulig hvis du bruker Hvisfeil(). I bildet under kan du se at B4 og B6 får verdien #I/T, men B7 returnerer ikke noe.

Ser du formelen i B7 som vises i C7, er Finn.Rad omsluttet av Hvisfeil.

Vi myser litt på denne formelen

=HVISFEIL(FINN.RAD(A7;D:E;2;USANN);»»)

Til slutt i formelen står verdien som Hvisfeil skal returnere hvis Finn.RAD feiler, i dette tilfellet «» – altså ingenting. Hvis du vil at formelen skal returnere noe annet, f.eks teksten «Feil», blir formelen

=HVISFEIL(FINN.RAD(A7;D:E;2;USANN);»Feil»)

Skal den returnere 0 (null), blir den

=HVISFEIL(FINN.RAD(A7;D:E;2;USANN);0)

Se også denne artikkelen:

https://www.excelguru.no/funksjonen-hvisfeil/

 

Ha en fin dag!


Spørsmål

Hei
Jeg lurer på om du kan hjelpe meg litt med HVIS kommandoen,
Jeg har en celle (F4) som inneholder ett tall mellom 1 og 20.
Jeg vil at G4 skal returnere en tallverdi mellom 1 og 3.
Den skal vise 1 om F4 er under 5. Den skal vise 2 om F4 er mellom 5 og opp til 10, og over 10 skal returner tallet 3.
Glad for hjelp 🙂

 

Svar

Hei på deg.

Formelen blir

=HVIS(F5<5;1;HVIS(F5>10;3;HVIS(F5>5;2)))

Ha en fin dag!


Spørsmål

Hei
Sitter nå med litt høyt koffein nivå fordi jeg ikke finner måten å lese ut samme cellereferanse fra multiple ark ( 189 ark.. i samme bok)

Skulle lest ut verdien fra c3 i alle arkene til nytt ark der jeg ønsker å liste disse løpende under hverandre i samme kolonne.

Må da finnes en enkel måte for dette? – bortsett fra mer kaffe 🙂 …

Svar

Hei på deg!

Håper du ikke har sittet våken i  de 11 dagene det har tatt før jeg svarte deg.

1) Liste fra alle ark.
Dette forutsetter at du har en nummerering av fanene. I dette eksemplet heter fanene Ark1, Ark2 osv, og formelen henter ut verdien i A1 i alle arkene. Da kan du lage listen fra A1 med formelen
=INDIREKTE(«Ark» & RAD() & «!C3»)
… og dra den 189 linjer nedover.

Hvis første fane ikke er nummer 1, kan du justere med f.eks RAD()-1 eller RAD()+10

2) Dette har du ikke bedt om, men morsomt er det:
Hvis du vil summere samme celle fra alle arkene:
Lag en tom fane som f.eks heter «First» før den første av de 189 arkene og en fane som heter «Last» etter den siste fanen du vil summere.
Så kan du lage en lekker liten formel:
=Summer(First:Last!A1)

Ha en fin dag!


Spørsmål

Vi mottar prisfiler fra leverandører i forskjellige format, som jeg tilpasser i Excel før innlesing i Visma. En av disse leverandørene har mange artikkelnummer som f.eks 0009999999, men i Excel har de brukt en kolonneformatering for å vise nullene, om man trykker på cellen vises i «formelfeltet» kun 9999999. Nullene blir ikke med uansett hvordan jeg prøver å lagre/eksportere filen og jeg får ikke lest inn rett artikkelnummer i Visma. Har dere noen tips angående dette? Jeg har mange sene kveldstimer rundt dette og denne leverandøren.

Svar

Hei på deg.
Dette er kjent:)

Lag en hjelpekolonne hvor du bruker denne formelen (Forutsatt at artikkelnummer er i A-kolonnen):
=HVIS(ERTALL(A2);TEKST(A2;»0000000000″);A2)

Den vil konvertere tallet til tekst.
Litt skummelt hvis samme leverandør også har andre formater på artikkelnumrene som ikke har de innledende nullene…

Vennlig hilsen Ketil


Spørsmål

Hei. Jeg har ikke lengre alfabetisk kolonneoverskrift i Excel. Har fått numerisk. Celle A1 heter nå R1C1. Hvordan får jeg endret dette tilbake?

R1C1 referansestil

Svar

Don’t panic :)Da har du fått huket på R1C1-referansestil under Alternativer->Formler. Fjern huken, så blir livet som normalt igjen.

R1C1 referansestil

Vennlig hilsen Ketil

 


Spørsmål

Hei, ble kjørt en oppdatering til Windows 10 og da virker ikke fakturamalen (Lage faktura i Excel og sende som PDF fra Outlook). Det har virket fremragende frem til nå.

Når jeg trykker på «lagre pdf» kommer vedlagte melding opp – som jeg ikke kommer videre fra. Er det mulig å få noe hjelp med det?

Svar

Jeg er litt i det blå her, men forsøk :

1) Avslutt Excel
2) Sett Microsoft XPS Document Writer som standardskriver i Windows
3) Start fakturamalen og forsøk igjen.
Vennlig hilsen Ketil
Tilbakemelding

Flott, tusen takk!

Nå virker det!!